Your host needs to use PHP 5.3.3 or higher to run this version of Joomla!